السلام عليكم
نشكركم على زيارة منتديات الشمال السحرية
وندعو زوارنا الكرام للتسجيل في المنتدى وذلك بالضغط على رابط التسجيل
كما ندعو اعضاءنا الافاضل للمشاركة الفعالة في المنتدى للرقي به الى الامام
شكرا لكم

مدير المنتدى : محمد علي سليمان



 
الرئيسيةالبوابةاليوميةمكتبة الصورس .و .جبحـثالأعضاءالمجموعاتالتسجيلدخول

شاطر | 
 

 الغوريتم يشمل اهم وضائف البرمجة

استعرض الموضوع السابق استعرض الموضوع التالي اذهب الى الأسفل 
كاتب الموضوعرسالة
Admin
ادارة المنتدى
ادارة المنتدى
avatar

عدد المساهمات : 250
النقاط : 479147
السٌّمعَة : 246
تاريخ التسجيل : 06/10/2009
العمر : 27
الموقع : www.magic-nord.co.cc

مُساهمةموضوع: الغوريتم يشمل اهم وضائف البرمجة   السبت 02 يناير 2010, 07:36

اعزائي المبرمجون اليكم هدا البرنامج الدي يضم اغلب متطلبات البرمجة .ارجوا ان اكون قد توفقت في تقريب الفكرة اليكم.رغم معاتبة المشرفين على التقصير في الشرح



--------------------------------------------------------------------------------


*اولا يتم ابلاغ البرنامج بالمتغيرات العامة تفاديا الاعادتها كل مرة*Type Stagiaire = STRUCTURE

Nom : Chaîne

Prenom : Chaîne

Note(3) : Réel

Fin STRUCTURE

*اولا يتم ابلاغ البرنامج بالمتغيرات المحلية تفاديا الاعادتها كل مرة*Variables choix, Ch1 : Chaîne

s1 : Stagiaire

i, j, N, pos : Entier

Note1, Moy : Réel

Tableaux s() : Stagiaire

Début

Répéter *هدا لعداد يقوم باعادة اضهار لائحة المطالب الى ات يتم انهاء البرنامج اي case5

Clear() //Effacer écran

*قائمة الرغبات*

Ecrire"1 : pour ajouter un stagiaire

Ecrire "2 : pour supprimer un stagiaire

Ecrire "3 : pour modifier une note d’un stagiaire

Ecrire "4 : pour afficher la liste des stagiaires

Ecrire "5 : pour quitter

Ecrire "Entrez votre choix

Lire choix

*تقوم باضهار كل مطلب اي 1.2.3.4او 5للانهاء البرنامج* Selon choix

*الحالة1 نقوم باضافة معلومات الطالب* "1" : case

Ecrire "Entrez le nom*ادخال الاسم

Lire s1.Nom

Ecrire "Entrez le prenom * ادخال الاسم الشخصي

Lire s1.Prenom

Pour j←1 à 3 *عداديقوم بادخال 3 نقط

Ecrire "Entrez la note num :", j

Lire s1.Note(j

Fin pour

pos←1

tant que s(pos).Nom<s1.Nom et pos<N *يقوم هدا العداد باختبار الموضع والعدد اللازم من الطلبة*

pos←pos+1

fin tant que

si pos=N

pos←pos+1

fin si

N←N+1

Redim s(N

Pour i←N à pos+1

s(i)←s(i-1)

Fin pour

s(pos)←s1

Ecrire "Ajout effectué"

*الحالة1 نقوم بمسح معلومات طالب معين* "2" : case

*ادخال الطالب المراد مسحه*Ecrire "Entrez le nom à supprimer

Lire Ch1

pos←-1

pour i←1 à N *التحقق من ان هدا الطالب ضمن الائحة*

si s(i).Nom=ch1

pos←i

fin si

fin pour

si pos<>-1 alors

Pour i←pos à N-1

s(i)←s(i+1

Fin pour

N←N-1

Redim s(N

Ecrire "Suppression effectuée"

Sinon

Ecrire "Ce nom n’existe pas"

Fin si

*الحالة1 نقوم بتعديل معلومات طالب معين* "3 ":case

Ecrire "Entrez le nom à modifier *ادخال الاسم القديم اللطالب المراد تعديله*

Lire Ch1

pos←-1

pour i←1 à N

si s(i).Nom=ch1

pos←i

fin si

fin pour

si pos<>-1 alors

Ecrire "Entrez la nouvelle note *يطلب البرتامج بادخال المعلومات الجديدة*

Lire Note1

Ecrire "Entrez la position de la

note à modifier

Lire j

s(pos).Note(j)←Note1

Ecrire "Modification effectuée"

Sinon

Ecrire "Ce nom n’existe pas"

Fin si

*اضهار لائحة الطلبة التهائية* "4" : case

Ecrire "Liste des notes

Pour i←1 à N

Moy←(s(i).Note(1)+s(i).Note(2)+s(i).Note(3))/3

Ecrire s(i).Nom, chr(9

s.Prenom(i), chr(9), Moy

Fin pour

*الحالة التهائية*case"5

Ecrire "Vous avez choisi de quitter

Sinon : Ecrire "Choix non traité

Fin selon

Jusqu’à choix="5"

Fin



--------------------------------------------------------------------------------
الرجوع الى أعلى الصفحة اذهب الى الأسفل
معاينة صفحة البيانات الشخصي للعضو http://www.magic-nord.tk
retrait-dev
مشرف
مشرف
avatar

عدد المساهمات : 132
النقاط : 149893
السٌّمعَة : 88
تاريخ التسجيل : 25/11/2009

مُساهمةموضوع: رد: الغوريتم يشمل اهم وضائف البرمجة   الخميس 14 يناير 2010, 10:55

عظيم هدا ما كان ينقصني
الرجوع الى أعلى الصفحة اذهب الى الأسفل
معاينة صفحة البيانات الشخصي للعضو
retrait-dev
مشرف
مشرف
avatar

عدد المساهمات : 132
النقاط : 149893
السٌّمعَة : 88
تاريخ التسجيل : 25/11/2009

مُساهمةموضوع: رد: الغوريتم يشمل اهم وضائف البرمجة   الخميس 14 يناير 2010, 11:02

تحية خاصة

الرجوع الى أعلى الصفحة اذهب الى الأسفل
معاينة صفحة البيانات الشخصي للعضو
MEEMO
مشرف
مشرف
avatar

عدد المساهمات : 165
النقاط : 144408
السٌّمعَة : 74
تاريخ التسجيل : 16/01/2010

مُساهمةموضوع: رد: الغوريتم يشمل اهم وضائف البرمجة   الأحد 24 يناير 2010, 04:37

meilleur explication je vous remercie on attend le plus
grande salutation
الرجوع الى أعلى الصفحة اذهب الى الأسفل
معاينة صفحة البيانات الشخصي للعضو
 
الغوريتم يشمل اهم وضائف البرمجة
استعرض الموضوع السابق استعرض الموضوع التالي الرجوع الى أعلى الصفحة 
صفحة 1 من اصل 1

صلاحيات هذا المنتدى:لاتستطيع الرد على المواضيع في هذا المنتدى
 :: منتدى طلاب ISTA :: التقني المتخصص في التنمية المعلوماتية TSDI-
انتقل الى: